Skip To Content

System Requirements

In this topic

Version 3.7

ArcGIS API for Flex system requirements

The following prerequisites will help you get started with the ArcGIS API for Flex:

Access to services

Optionally, access to ArcGIS Server 9.3 or later. If you do not have your own ArcGIS Server, you can work with services accessible from ArcGIS Online and elsewhere. Not all services used in the ArcGIS API for Flex need to be ArcGIS Server services. Please see Types of layers for additional information regarding what can be used within the API.

Apache/Adobe Flex SDK versions

Adobe Flex SDK 4.6 (or later). If not using the Adobe SDK, you can also use the Apache Flex SDK 4.8 parity release (or later). The Adobe Flex 4.6 SDK accompanies Adobe Flash Builder 4.6 and 4.7, but you can also download it separately if you are using an older version of Flash Builder, or if you are using a different IDE. For detailed Flex framework system requirements, read the Flex SDK system requirements.

Adobe Flash Player versions

Applications compiled with Adobe Flex SDK 4.6 or Apache Flex SDK 4.8 require the use of at least Adobe Flash Player 11.1. For more details, read the current Flash Player system requirements by Adobe.

Adobe AIR versions

When creating mobile applications using Adobe AIR, the minimum supported version is 3.1. For more details, read the current Adobe AIR system requirements by Adobe.


This is not to be confused with the 3.5 minimum version needed to run the ArcGIS Viewer for Flex Application Builder.

Development environments

The most popular Flex development environment is Adobe Flash Builder. It is not free; however, a 60-day evaluation version is available. The ArcGIS API for Flex is compatible with all versions of Flash Builder 4.6 and later. For detailed Adobe Flash Builder system requirements, read the current Flash Builder system requirements by Adobe.

Although Flash Builder is the environment used in the Getting started tutorial, it is not a requirement. You could write your own Flex code in a text editor, e.g. Notepad, and compile using the command-line with the free compiler. In addition to this, you could choose an alternative such as the open-source FlashDevelop and/or Microsoft Visual Studio plug-ins.

ArcGIS Server versions

Certain functionality requires a specific minimum version, for example, advanced printing requires ArcGIS Server 10.1 and editing requires ArcGIS Server 10.0. See the table below for additional information.

FunctionalitySpecific requirements


ArcGIS Server 10.0 or later.

Feature service using ArcSDE geodatabase.

Editing with versions

ArcGIS Server 10.1 or later.

Editing with ownership-based access control

ArcGIS Server 10.1 or later.

Time-aware layers

ArcGIS Server 10.0 or later.

Map or feature service with at least one time-enabled layer.

Routing using the routeTask

ArcGIS Server 9.3.1 or later.

Routing with polyline and polygon barriers

ArcGIS 10.0 or later. Prior to 10.0, only point barriers were supported.

NAServer service with a route layer.


ArcGIS Server 10.0 or later.

NAServer service with a closest facility layer.


ArcGIS Server 10.0 or later.

NAServer service with a service area layer.

Spatial references as well-known text (WKT)

ArcGIS Server 10.0 or later.

Prioer to 10.0, well-known ID (WKID) were only supported.

labelPoints and relation Geometry service operations.

ArcGIS Server 9.3 SP1 or laer.

autocomplete, convenxHull, cut, densify, difference, distance, generalize, intersect, offset, reshape, trimExtend, and union Geometry service operations.

ArcGIS Server 10.0 or later.


ArcGIS Server 10.0 or later.

Classbreak renderers in service

ArcGIS Server 10.1 or later.

Action Message Format (AMF) for FeatureLayer, Query, and Geoprocessor

ArcGIS Server 10.0 or later.

For earlier versions, set useAMF="false" for Query and Geoprocessor.

Queries to ImageServices using AMF

Not supported, set useAMF="false".

Query: order by fields, group by fields, and statistics

ArcGIS Server 10.1 or later

Batch geocoding

ArcGIS Server 10.1 or later.

Advanced printing using PrintTask

ArcGIS Server 10.1 or later.

Printing simplemarkersymbol of type, triangle, requires ArcGIS Server 10.1 SP1.

Working with versioned data, editing, query, find, and identify

ArcGIS Server 10.1 or later.