Skip To Content

System requirements for 10.2.5

In this topic

Supported operating systems for development

Intel-based Macintosh running Mavericks (OS X 10.9), Yosemite (OS X 10.10), El Capitan (OS X 10.11), or Sierra (macOS 10.12) is required.

Software requirements for development

To develop apps with this release of the ArcGIS Runtime SDK for iOS SDK you can use any version of :

  • Xcode 8 with the iOS 10 SDK
  • Xcode 7 with the iOS 9 SDK
  • Xcode 6 with the iOS 8 SDK.

We recommend that you use the latest version of Xcode to ensure that you have Apple's latest bug fixes, language support, and enhancements to both Xcode and the iOS SDKs.

Note:
Beta and GM seed versions of Xcode or iOS SDK are generally not supported unless otherwise noted.

The iOS Dev Center contains technical resources for developing iOS apps. You must to register as an Apple developer to access Apple programming guides, samples, videos, forums, downloads, and more.

Although Apple's iOS SDK contains a simulator, which provides a convenient way to run iOS applications on your Mac, it is recommended that you test your applications on actual devices to ensure they work and perform as expected. Testing on the simulator alone does not provide a good measure of how the application performs on the physical device.

ArcGIS for Server or Portal

To connect your app to ArcGIS for Server data or services, use ArcGIS for Server version 10.0 or later. To use ArcGIS for Server data when your app is offline, use ArcGIS for Server 10.2.2 or later.

You can use ArcGIS for Portal version 10.2 or later with your Runtime apps.

Device requirements for deployment

Applications built with this release of ArcGIS Runtime SDK for iOS can be deployed to iPhone, iPad, and iPod Touch devices that are running either iOS 10, iOS 9, iOS 8, or iOS 7.

Note:

Beta and GM seed versions of iOS are generally not supported unless otherwise noted.

Related topics