System requirements for 10.2.4

This topic provides system requirements for ArcGIS Runtime SDK 10.2.4 for Java.

Supported operating systems

Supported Linux Operating SystemMinimum OS VersionMaximum OS Version

Red Hat Enterprise Linux Server 6 (32-bit and 64-bit)

Update 2

Ubuntu 12.04 LTS (32-bit and 64-bit)

Ubuntu 14.04 LTS (32-bit and 64-bit)

Supported Windows Operating SystemMinimum OS VersionMaximum OS Version

Windows 8.1 Basic, Pro and Enterprise (32 bit and 64 bit [EM64T])

Update: April 2014*

Windows 7 Ultimate, Professional Edition (32-bit and 64-bit (EM64T))

SP1

Windows 2012 R2 Server Standard and Datacenter (64 bit (EM64T))

Update: April 2014*

Windows 2012 Server Standard and Datacenter (64 bit (EM64T))

Windows 2008 R2 Server Standard, Enterprise, and Datacenter (64-bit (EM64T))

SP1

Windows 2008 Server Standard, Enterprise, and Datacenter (32-bit and 64-bit (EM64T))

SP2

SP2

Note:

*Windows 8.1 and Windows Server 2012 R2 Update: April 2014 support begins at ArcGIS Runtime SDK for Java 10.2.3

Hardware requirements

CPU Speed

2.2 GHz minimum or higher; Hyper-threading (HHT) or Multi-core recommended

Processor

Intel Pentium 4, Intel Core Duo, or Xeon Processors; SSE2 minimum

Windows: Run this Microsoft utility from your Windows command prompt to check your processor.

Disk Space

Windows: 1.3 GB of available disk space

Linux: 1.8 GB of available disk space

Memory/RAM

2 GB or higher

Display Properties

24-bit color depth

Screen Resolution

1024 x 768 recommended or higher at normal size (96 dpi)

Swap Space

Determined by the operating system; 500 MB minimum.

ArcGIS Runtime will create cache files when used; additional disk space may be required.

Video/Graphics Adapter

64 MB RAM minimum; 256 MB RAM minimum recommended; NVIDIA, ATI, and INTEL chipsets are supported.

A graphics card with a hardware acceleration driver is required.

Applications running in OpenGL mode require support for OpenGL 2.1 and Shader Language 1.2 minimum. Graphics cards on some Windows platforms may require OpenGL support of 3.3.

User Interface

Linux: X Windows with Gnome or KDE Desktop Environment

Software requirements

ArcGIS Runtime SDK for Java has been certified against Java Development Kits (JDK) 7 update 67, and 8 update 20.

Note:

Starting at the 10.2.4 version of ArcGIS Runtime SDK for Java, JDK 6 is no longer supported.

Supported and Recommended IDE(s)

Developer IDE plug-ins, which offer an enhanced developer experience through templates, code snippets, and project wizards, are provided with the ArcGIS Runtime SDK for Java and supported in the IDEs listed below.

  • Eclipse Luna IDE for Java Developers
  • Eclipse Luna IDE for Java EE Developers
  • Eclipse Kepler IDE for Java Developers
  • Eclipse Kepler IDE for Java EE Developers
  • Eclipse Juno IDE for Java Developers
  • Eclipse Juno IDE for Java EE Developers

Note:

If you are developing using Java 8, please ensure your version of Eclipse supports Java 8. Versions of Eclipse exist with a Java 8 patch, or you can install the patch to Eclipse Kepler yourself. See the Eclipse downloads' Java 8 support page for details.

Red Hat Enterprise Linux Server 6.2 and above:

  • ArcGIS Runtime SDK for Java and its deployments are only supported on CPUs that adhere to the x86 and x86_64 architectures.
  • It is a requirement that the OS (binary) has not been modified. Esri does not provide any support if products are installed on Developer's Release of an Operating System.
  • The Linux patches from RHEL Server will be supported as long as the patches are from Red Hat without any modification to the latest kernel/glibc version.

The following Libraries are required, along with the packages that provide them:

Library

Package Name

Package Version

libc.so.6

glibc

2.12-1.43

libdl.so.2

libm.so.6

librt.so.1

libpthread.so.0

ld-linux.so.2 (32-bit only)

ld-linux-x86-64.so.2 (64-bit only)

libGL.so.1*

mesa-libGL

7.11-1

libX11.so.6

libX11

1.3-2

libXau.so.6

libXau

1.0.5-1

libXdamage.so.1

libXdamage

1.1.2-1

libXext.so.6

libXext

1.1-3

libXfixes.so.3

libXfixes

4.0.4-1

libdrm.so.2

libdrm

2.4.25-1

libexpat.so.1

expat

2.0.1-9.1

libfreetype.so.6

freetype

2.3.11-6

libfontconfig.so.1

fontconfig

2.8.0-3

libgcc_s.so.1

libgcc

4.4.6-3

libstdc++.so.6

libstdc++

4.4.6-3

libxcb.so.1

libxcb

1.5-1

libXxf86vm.so.1

libXxf86vm

1.1.0-1

* The libGL.so.1 may be provided by the graphics driver vendor. The mesa OpenGL lib is only needed when there are no other graphics drivers installed. For example, on a RHEL 6.2 system using an NVIDIA video card, /usr/lib64/libGL.so.1 is a symlink to /usr/lib64/libGL.so.319.60, which is provided by the NVidia driver.

Ubuntu LTS Linux

  • ArcGIS Runtime SDK and its deployments are only supported on CPUs that adhere to the x86 and x86_64 architectures.
  • It is a requirement that the OS (binary) has not been modified. Esri does not provide any support if products are installed on Developer's Release of an Operating System.
  • The Linux patches from Ubuntu will be supported as long as the patches are from Ubuntu without any modification to the latest kernel/glibc version.

The following Libraries are required, along with the packages that provide them:

Library

Package Name

Package Version

libm.so.6

libc6 (glibc)

2.15

libpthread.so.0

libc.so.6

libdl.so.2

/lib/ld-linux.so.2 (32-bit only)

/lib64/ld-linux-x86-64.so.2 (64-bit only)

libX11.so.6

libx11-6

2:1.4.99.1

libXau.so.6

libxau6

1:1.0.6-4

libXext.so.6

libxext6

2:1.3.0

libXdmcp.so.6

libxdmcp6

1:1.1.0

libexpat.so.1

libexpat1

2.0.1

libfontconfig.so.1

libfontconfig1

2.8.0

libfreetype.so.6

libfreetype6

2.4.8

libGL.so.1*

libgl1-mesa-glx

8.0.4

libgcc_s.so.1

libgcc1

1:4.6.3

libstdc++.so.6

libstdc++6

4.6.3

libxcb.so.1

libxcb1

1.8.1

libz.so.1

zlib1g

1:1.2.3

* The libGL.so.1 may be provided by the graphics driver vendor. The mesa OpenGL lib is only needed when there are no other graphics drivers installed.

Other requirements

To connect your app to ArcGIS for Server data or services, use ArcGIS for Server version 10.0 or later. To use ArcGIS for Server data when your app is offline, use ArcGIS for Server 10.2.2 or later.

You can use ArcGIS for Portal version 10.2 or later with your Runtime apps.

Related topics