Skip To Content

System requirements for 10.2.4

In this topic

Supported operating systems

Objective-C

To develop and run applications built with Objective-C, you and your target users will need any Apple Mac computer running Mountain Lion or higher (OS X 10.8).

Swift

To develop and run applications built with Swift, you and your target users will need any Apple Mac computer running Yosemite or higher (OS X 10.10).

Software requirements

We recommend that you follow Apple's steps to setting up your Mac development environment. The key elements are:

  • We always recommend that you install the latest version of Xcode for your development.
  • For Objective-C development install at least Xcode 5.0
  • For Swift development install at least Xcode 6.1
  • Xcode comes prebundled with the Apple OS X SDK, an SDK that contains documentation, frameworks, and tools to help you develop OS X applications.
  • Register in the Mac Developer Program to get the tools you need to develop and distribute your application.
  • The Mac Getting Started section contains a wealth of information and technical resources for developing OS X apps.

ArcGIS for Server or Portal

To connect your app to ArcGIS for Server data or services, use ArcGIS for Server version 10.0 or later. To use ArcGIS for Server data when your app is offline, use ArcGIS for Server 10.2.2 or later.

You can use ArcGIS for Portal version 10.2 or later with your Runtime apps.

Hardware requirement

  • 2 GHz or faster processor
  • 2 GB of RAM
  • 30 MB of available hard disk space
  • 1024 x 768 or higher display resolution