System requirements for 100.2.0

Supported operating systems for development

Macintosh running macOS High Sierra (10.13) or macOS Sierra (10.12) is required.

Software requirements for development

To develop apps with this release of the ArcGIS Runtime SDK for macOS you can use any version of Xcode 9 and macOS 10.13 SDK. You can use Objective-C or Swift to develop your apps. We recommend that you use the latest version of Xcode to ensure that you have Apple's latest bug fixes, language support, and enhancements to both Xcode. Note that:

  • Xcode comes prebundled with Apple's Mac SDK, an SDK that contains documentation, frameworks, and tools to help you develop Mac applications.
  • You must register as an Apple developer in the Mac Developer Program to access the Apple programming guides, samples, videos, forums, downloads, and more.

Requirements for ArcGIS software and connected services

To connect your app to ArcGIS for Server data or services, use ArcGIS for Server version 10.2 or later. To use ArcGIS for Server data when your app is offline, use ArcGIS for Server 10.2.2 or later.

You can use Portal for ArcGIS version 10.2 or higher with your Runtime apps. However, when your app uses web maps, it must use web maps built with the 2.0 or higher version of the web map specification, which come from Portal for ArcGIS 10.3 and higher. When you save a web map in an ArcGIS Runtime app, you are saving a web map that adheres to version 2.9 of the web map specification. These should only be saved back to portals which support the 2.0 web map specification.

ArcGIS Pro 1.3 or higher is required if you're using mobile map packages and tile packages.

ArcGIS for Desktop 10.3 and higher is required if you’re using the Create Runtime Content capability.

Machine requirements for deployment

Applications built with this release of ArcGIS Runtime SDK for macOS can be deployed to machines running any version of macOS High Sierra (10.13) or macOS Sierra (10.12).

Beta and GM versions of macOS are generally not supported unless otherwise noted.

Hardware requirement

  • 2 GHz or faster processor
  • 2 GB of RAM
  • 30 MB of available hard disk space
  • 1024 x 768 or higher display resolution

Related topics