Skip To Content

System requirements

In this topic

Supported platforms (Windows)

Operating SystemsMinimum OS VersionMaximum OS Version

Windows 8.1 (x86 and x64)

Update: April 2014

Windows 8 (x86 and x64)

Windows 7 SP1 (x86 and x64)


Windows Server 2012 R2 (x64)

Update: April 2014

Windows Server 2012 (x64)

Windows Server 2008 R2 SP1 (x64)



ArcGIS Runtime SDK for Qt uses ANGLE, which renders using DirectX, to provide high-performance map rendering. DirectX provides support for hardware and software rendering of graphics, and is provided by the supported Windows platforms. DirectX software rendering is used if DirectX hardware support is not available (including on Virtual Machines.)

Supported platforms (Linux)

Operating SystemsMinimum OS VersionMaximum OS Version

Ubuntu 12.04 LTS (64-bit)

Ubuntu 14.04 LTS (64-bit)

Red Hat Enterprise Linux 6 (64-bit)



  • An operating system can only be supported if it is also supported by the Qt SDK from The Qt Company.
  • ArcGIS Runtime SDK and its deployments are only supported on CPUs that adhere to the x86 architecture.
  • It is a requirement that the operating system binary has not been modified. Esri does not provide support if products are installed on the developer's release of an operating system.
  • The Linux patches from Ubuntu will be supported as long as the patches are from Ubuntu without any modification to the latest kernel/glibc version.

Refer to the list of platform-specific required libraries for Ubuntu LTS Linux and Red Hat Enterprise Linux.

Hardware requirements

CPU Speed

2.2 GHz minimum or higher; Hyper-threading (HHT) or Multi-core recommended


Intel Pentium 4, Intel Core Duo, or Xeon Processors; SSE2 minimum

Windows: Run this Microsoft utility from your Windows command prompt to check your processor.


2 GB or higher

Display Properties

24-bit color depth

Screen Resolution

1024 x 768 recommended or higher at normal size (96 dpi)

Swap Space

Determined by the operating system; 500 MB minimum

ArcGIS Runtime will create cache files when used; additional disk space may be required.

Disk Space

The ArcGIS Runtime SDK for Qt requires 2 GB of available disk space.

User Interface

Linux: X Windows with Gnome or KDE Desktop Environment

Video/Graphics Adaptor

64 MB RAM minimum; 256 MB RAM minimum recommended; NVIDIA and INTEL chipsets are supported.

A graphics card with a hardware acceleration driver

Linux: OpenGL version 2.1 runtime minimum and Shader Model 1.2 minimum

Windows: Shader Model 2.0 minimum

Be sure to use the latest available driver.

Software requirements

Development OSSupported and Recommended IDESDK Requirements


Qt Creator version 3.3.x or higher

Qt SDK for Windows version 5.4.1 minimum (msvc2013)

To access HTTPS or SSL-enabled web services on Windows, the Qt SDK requires the latest SSL/OpenSSL libraries be installed. See your operating system documentation for more information.

Microsoft Visual Studio 2013 C++ compiler

Microsoft XML Core Services (MSXML) 6.0

Microsoft .NET Framework 4.0

Microsoft .NET Framework 4.5

Ubuntu Linux

Qt Creator version 3.3.x or higher

Qt SDK for Linux version 5.4.1 minimum

Red Hat Linux 6

Qt Creator 2.7.2

Esri provides a special build of the Qt SDK for use with Red Hat Enterprise Linux 6. See Install and set up on Linux for more information.

ArcGIS for Server or Portal

To connect your app to ArcGIS for Server data or services, use ArcGIS for Server version 10.0 or later. To use ArcGIS for Server data when your app is offline, use ArcGIS for Server 10.2.2 or later.

You can use Portal for ArcGIS version 10.2 or later with your Runtime apps.