Skip To Content ArcGIS for Developers Sign In Dashboard

System requirements for 100.6.0

This page lists system requirements for the 100.6.0 release of ArcGIS Runtime SDK for Qt. The system requirements are the same for developing apps whether you're using the C++ API or the QML API. See the sections below for the requirements for your development machine and target platform.

View system requirements for past releases by downloading past guide versions in PDF format from the downloads page (requires sign-in).

OpenSSL

Because ArcGIS Runtime SDK makes network requests over https, your app requires OpenSSL to access all services with Windows, Linux, and Android. macOS and iOS make use of secure transport which should already be available on those platforms. OpenSSL is not delivered with the Qt Framework. For more information, see the Qt documentation about adding SSL support to your Qt application and the Qt SSL Classes and Qt 5.12.4 Released with support for OpenSSL 1.1.1. Verify that the version of OpenSSL you deploy is supported by your Qt version.

You can obtain OpenSSL from http://www.openssl.org/, or from https://github.com/openssl/openssl: different branches in the GitHub repository correspond to different versions of OpenSSL. Make sure that the OpenSSL libraries are available in the Qt environment when building Qt (that is, the paths to the OpenSSL include and lib folders). The exact setup required will depend on your system configuration but may include the general guidance below:

  • On Windows, you may need to copy libeay32.dll and ssleay32.dll to the bin folder of your Qt kit. Note that the names of these DLLs are XXX32.dll regardless of the architecture they are built for.
  • For Android, you may need to copy libcrypto.so and libssl.so to the lib folder of your kit.
  • For most Linux distribute versions, OpenSSL should already be installed. If not, then install the package supported by your Linux distribute version. If the required package is not available, you may need to build it yourself.

Requirements for developing on Linux

Using Linux as your development environment, you can develop apps for Linux and Android. See Requirements for Android on this page for a list of additional software needed for Android app development.

Linux VersionNotes

Red Hat Enterprise Linux Server (64-bit)

Minimum version is 7

Ubuntu (64-bit)

18.04 LTS

Ubuntu (64-bit)

16.04 LTS

SUSE Linux Enterprise Desktop (64-bit)

Minimum version is 12 LTS

Qt 5.12.0 builds that are released by the Qt Company will not run out of the box on SLES 12. See note below.

SoftwareVersionsNotes

Qt Framework for Linux

5.12.0 or higher

Qt Creator

4.4.1 or higher

Qt Creator is the recommended IDE.

OpenGL

See Video graphics adapter (below)

Using Mesa software rendering is not supported with ArcGIS Runtime for Qt.

HardwareMinimumNotes

CPU Type

x86 family

Hyper-threading (HHT) or Multi-core recommended.

Video graphics adapter

OpenGL 2.1 for 2D map views, 3.2 for 3D scene views

Shader Model 1.2

Hardware video adapter is required. Be sure to use the latest available driver.

Notes

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

Due to this Qt Company issue, the Qt 5.12.0 builds that are released by the Qt Company will not run out of the box on SLES 12. The Qt builds depend on a higher version of the dbus library than the one contained in the SLES 12 system packages. The Qt Company offers two suggested work-arounds in the above referenced bug. We have tested the suggestion of building and using a newer version of dbus and can confirm the Runtime SDK for Qt works in this environment.

ArcGIS Runtime SDK and its deployments are only supported on CPUs that adhere to the x86 architecture.

It is a requirement that the operating system binary has not been modified. Esri does not provide support if products are installed on the developer's release of an operating system.

Linux patches from Ubuntu will be supported as long as the patches are from Ubuntu without any modification to the latest kernel/glibc version.

Requirements for developing on macOS

Using macOS as your development environment, you can develop apps for macOS, iOS, and Android. See See Requirements for Android on this page and See Requirements for iOS on this page for a list of additional software needed for Android and iOS app development.

Operating systemsVersionNotes

Mojave

10.14

High Sierra

10.13

SoftwareVersionsNotes

Qt Framework for macOS (OS X)

5.12.0 or higher

Qt Creator

4.8.0 or higher

Qt Creator is the recommended IDE.

Xcode

10.1.0 or higher

Including Xcode Command Line Tools.

Notes

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

Requirements for developing on Windows

Using Windows as your development environment, you can develop apps for Windows and Android. See Requirements for Android on this page for a list of additional software needed for Android app development.

Supported operating systems:

  • Windows 10 (64-bit)—Minimum version is 1703 (Build 15063 / Creators Update)
  • Windows 8.1 (64-bit)—Minimum version is Update KB2919355
  • Windows 7 (64-bit)—Minimum version is SP1
  • Windows Server 2019 (64-bit)
  • Windows Server 2016 (64-bit)
  • Windows Server 2012 R2 (64-bit)—Minimum version is Update KB2919355
  • Windows Server 2012 (64-bit)—Minimum version is Update KB2919355

SoftwareVersionsNotes

Qt Framework for Windows

5.12.0 or higher

MSVC2017 (64-bit)

Qt Creator

4.8.0 or higher

Qt Creator is the recommended IDE.

OpenGL

See Video graphics adapter (below)

Microsoft Visual Studio C++ compiler

15.9.5

Deployed apps need these Microsoft Visual Studio 2017 DLLs to run: msvcp140.dll and vcruntime140.dll.

HardwareMinimumNotes

CPU Type

x86 family

Hyper-threading (HHT) or Multi-core recommended.

Video graphics adapter

OpenGL 2.1 for 2D map views, 3.2 for 3D scene views

Shader Model 1.2

Be sure to use the latest available driver.

Notes

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

Requirements for deploying your apps

Requirements for deploying to Android

Operating systemsMinimum version

Android

armv7: 4.4 "KitKat" (API 19)

armv8: 5.0 "Lollipop" (API 21)

SoftwareVersionsNotes

Qt Framework for Android

5.12.0 or higher

5.12.0 uses the Android-Clang toolchain rather than GCC.

Qt Creator

4.8.0 or higher

Qt Creator is the recommended IDE.

Android SDK Tools

API 4.4 (19) or higher

Android SDK Build Tools

Rev 19.1 or higher

NDK

Recommended version 18b

Per Qt Company recommendation.

Java Development Kit (JDK)

8.x

Notes

Android armv7 and armv8 are supported. Set the following environment variables when targeting these platforms:

  • armv7: ANDROID_NDK_PLATFORM=android-19
  • armv8: ANDROID_NDK_PLATFORM=android-21
armv8 processors have 64-bit architecture. There are potential performance benefits with 64-bit processors over 32-bit for high memory use operations. Also, the Google Play store submissions must support armv8 starting in August 2019. See https://developer.android.com/distribute/best-practices/develop/64-bit.

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

Requirements for deploying to iOS

Operating systemsMinimum version

iOS

11.x

SoftwareVersionsNotes

Qt Framework for iOS

5.12.0 or higher

Qt Creator

4.8.0 or higher

Qt Creator is the recommended IDE.

Xcode

10.1.0 or higher

Including Xcode Command Line Tools.

Notes

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

Requirements for ArcGIS software and connected services

To use ArcGIS Server data or services in your app, use ArcGIS Server version 10.3 or later. To use ArcGIS Server data when your app is offline, use ArcGIS Server version 10.3 or later.

To create mobile map packages for use in your ArcGIS Runtime SDK apps, use ArcGIS Pro version 2.2 or later.

To create mobile scene packages for use in your ArcGIS Runtime SDK apps, use ArcGIS Pro version 2.3 or later.

To create next generation locators (*.loz), use ArcGIS Pro version 2.3 or later. Next generation locators are only supported on 64-bit apps.

To create annotation layers for use in your ArcGIS Runtime SDK apps, use ArcGIS Pro version 2.3 or later. Annotation layers can be published to mobile map packages or to a service that uses ArcGIS Enterprise version 10.7 or later.

ArcGIS Desktop version 10.3 or later is required if you're using the Create Runtime Content capability. You can create ArcGIS Runtime SDK content in the ArcMap user interface or with the Create Runtime Content geoprocessing tool.

ArcGIS Runtime SDK works with ArcGIS Enterprise version 10.3 or later portals, and web maps created with these portals.

ArcGIS Runtime SDK works with utility network schema versions 2 and 3.

Local Server is supported with the C++ API on Windows and Linux. Local Server is not supported on Android, iOS, or macOS. Local Server cannot be used with the QML API.

Versions of supported specifications

Specifications supported at 100.6.0 include the following:

  • GeoPackage versions 1.0, 1.1, and 1.2
  • Military standards APP-6(B), APP-6(D), MIL-STD-2525B (change 2), MIL-STD-2525C, and MIL-STD-2525D
  • Web Feature Service (WFS) versions 2.0.0 and 2.0.2
  • Web Map Service (WMS) versions 1.1.0, 1.1.1, and 1.3.0
  • WMTS version 1.0.0
  • I3S version 1.6

On-premises virtualization

On-premises virtual desktop infrastructure (VDI)

VMware

ProductHypervisorNotes

VMware Horizon View 6.5

VMware vSphere 6.5

Use the latest VMware and NVIDIA drivers. Refer to VMware and NVIDIA GRID websites for the most current driver versions.

VMware Horizon View 7.0

VMware vSphere 6.5

VMware Horizon View 7.6 and 7.9

VMware vSphere 6.7

Citrix

ProductHypervisorNotes

Citrix XenDesktop 7.17

VMware vSphere 6.5

Use the latest Citrix and NVIDIA drivers. For the most current driver versions, see the Citrix and NVIDIA GRID websites.

Citrix XenDesktop 7.18

VMware vSphere 6.7

Citrix Virtual Apps and Desktops 7 1906

VMware vSphere 6.7

Citrix XenDesktop 7.6 LTSR CU7

VMware vSphere 6.5

Citrix XenDesktop 7.15 LTSR CU4

VMware vSphere 6.7

Related topics