System requirements for 100.9

This page lists system requirements for the 100.9 release of ArcGIS Runtime SDK for Qt.

The system requirements are the same for developing apps whether you're using the C++ API or the QML API. See the sections below for the requirements for your development machine and target platform.

OpenSSL

Because ArcGIS Runtime SDK makes network requests over https, your app requires OpenSSL to access all services with Windows, Linux, and Android. macOS and iOS make use of secure transport which should already be available on those platforms. OpenSSL is not delivered with the Qt Framework. For more information, see the Qt documentation about adding SSL support to your Qt application and the Qt SSL Classes and Qt 5.12.4 Released with support for OpenSSL 1.1.1. Verify that the version of OpenSSL you deploy is supported by your Qt version.

You can obtain OpenSSL from http://www.openssl.org/, or from https://github.com/openssl/openssl: different branches in the GitHub repository correspond to different versions of OpenSSL. Make sure that the OpenSSL libraries are available in the Qt environment when building Qt (that is, the paths to the OpenSSL include and lib folders). The exact setup required will depend on your system configuration but may include the general guidance below:

  • On Windows, you may need to copy libcrypto-1_1-x64.dll and libssl-1_1-x64.dll to the bin folder of your Qt kit.

  • For Android, refer to documentation from the Qt company on Adding Open SSL.

  • On Linux, you may need to copy libcrypto.so and libssl.so to the bin folder of your Qt kit.

Developing apps on Linux

Using Linux as your development environment, you can develop apps for Linux and Android. See the Deployment topic for a list of additional software needed for Android app development.

LinuxVersionNotes
Red Hat Enterprise Linux Server (64-bit)Minimum version is 7.6GCC 5.3.1 is the minimum version compiler.
Ubuntu (64-bit)18.04 LTS
Ubuntu (64-bit)20.04 LTS
SUSE Linux Enterprise Desktop (64-bit)Minimum version is 15 LTS
SoftwareVersionsNotes
Qt Framework for Linux5.15
Qt Creator4.12.1 or higherQt Creator is the recommended IDE.
OpenGLSee Video graphics adapter (below)Using Mesa software rendering is not supported with ArcGIS Runtime for Qt.
HardwareMinimumNotes
CPU Typex86 familyHyper-threading (HHT) or Multi-core recommended.
Video graphics adapterOpenGL 2.1 for 2D map views, 3.2 for 3D scene views Shader Model 1.2Hardware video adapter is required. Be sure to use the latest available driver.

Notes

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

ArcGIS Runtime SDK and its deployments are only supported on CPUs that adhere to the x86 architecture.

It is a requirement that the operating system binary has not been modified. Esri does not provide support if products are installed on the developer's release of an operating system.

Linux patches from Ubuntu will be supported as long as the patches are from Ubuntu without any modification to the latest kernel/glibc version.

Developing apps on macOS

Using macOS as your development environment, you can develop apps for macOS, iOS, and Android. See the Deployment topic for a list of additional software needed for Android and iOS app development.

Operating systemsVersionNotes
Catalina10.15
Mojave10.14
SoftwareVersionsNotes
Qt Framework for macOS (OS X)5.15
Qt Creator4.12.1 or higherQt Creator is the recommended IDE.
Xcode11.3.1 or higherIncluding Xcode Command Line Tools.

Notes

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

Developing apps on Windows

Using Windows as your development environment, you can develop apps for Windows and Android. See the Deployment topic for a list of additional software needed for Android app development.

Supported operating systems:

  • Windows 10 (64-bit)—Minimum version is 1803
  • Windows 8.1 (64-bit)—Minimum version is Update KB2919355
  • Windows Server 2019 (64-bit)
  • Windows Server 2016 (64-bit)
  • Windows Server 2012 R2 (64-bit)—Minimum version is Update KB2919355
  • Windows Server 2012 (64-bit)—Minimum version is Update KB2919355
SoftwareVersionsNotes
Qt Framework for Windows5.15 MSVC2019 (64-bit)
Qt Creator4.12.1 or higherQt Creator is the recommended IDE.
OpenGLSee Video graphics adapter (below)
Microsoft Visual Studio C++ compiler16.1.6Deployed apps need these Microsoft Visual Studio 2017 DLLs to run: msvcp140.dll and vcruntime140.dll.
Microsoft Visual C++ 2015 - 2019 Redistributable (x64)14.21 minimum
HardwareMinimumNotes
CPU Typex86 familyHyper-threading (HHT) or Multi-core recommended.
Video graphics adapterOpenGL 2.1 for 2D map views, 3.2 for 3D scene views Shader Model 1.2Be sure to use the latest available driver.

Notes

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

Deploying your apps

Deploying apps to Android

Operating systemsMinimum version
Android5.1 "Lollipop" (API 22)
SoftwareMinimum versionsNotes
Qt Framework for Android5.155.15 introduces a single kit containing all architectures.
Qt Creator4.12.1Qt Creator is the recommended IDE.
Android SDK Toolsandroid-22
Android SDK Build ToolsRev 29.0.2
NDKMinimum version 21bLatest available version of NDK with the Android-Clang toolchain.
Java Development Kit (JDK)8.x

Notes

Android armv7 and armv8 are supported.

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

Deploying apps to iOS

Operating systemsMinimum version
iOSiOS 12.
SoftwareVersionsNotes
Qt Framework for iOS5.15
Qt Creator4.12.1 or higherQt Creator is the recommended IDE.
Xcode11.3.1 or higherIncluding Xcode Command Line Tools.

Notes

An operating system can only be supported if it is also supported by the Qt Framework from The Qt Company. It is recommended to use the latest supported version of the operating system. Learn more about Qt licensing terms and conditions at the Qt Company website.

ArcGIS software and connected services

Use this table to determine the lowest Version of the ArcGIS Software that supports a specific ArcGIS Runtime function.

ArcGIS SoftwareVersionFunctionality supported by the ArcGIS Runtime SDKs
ArcGIS Enterprise10.8
  • Standard and advanced Named User licensing supported
10.7.1
  • Scheduled updates to the feature services involved in the preplanned workflow (offline maps)
10.7
  • Annotation layers
10.6.1
  • Offline maps created using the preplanned workflow
10.4
  • Advanced parameters for the on-demand workflow (offline maps)
10.3
  • Web map and scene support.
  • Feature services.
  • Tiled services.
  • Offline maps created using the on-demand workflow.
ArcGIS Pro2.6
  • Online services for layers and tables are supported in mobile map and scene packages.
2.5
  • Elevation sources can use raster files in a mobile scene package.
  • Transportation networks in a mobile scene package.
  • Vector tile packages with custom styles in mobile map packages.
2.4
  • Expiration of mobile map and scene packages (requires the Publisher Extension)
  • Utility network (version 3)
2.3.2
  • Create a mobile scene package (.mspk)
2.3
  • Create annotation layers and publish in a mobile map package
  • Next generation (.loz) locators
2.2
  • Create a mobile map package (.mmpk)
  • Utility network (version 2)
ArcMap10.3
  • Create Runtime Content

Local Server version compatibility with ArcGIS Desktop and ArcGIS Pro

Local Server is supported with the C++ API on Windows and Linux. Local Server is not supported on Android, iOS, or macOS. Local Server cannot be used with the QML API.
ArcGIS Runtime Local Server versionArcGIS Desktop versionArcGIS Pro version
100.9.010.8.x2.6
100.8.010.8.x2.5
100.6.010.7.x2.4
100.5.010.72.3
ArcGIS Runtime 100.4.0ArcGIS Runtime Local Server 100.3.010.6.x2.2
100.3.010.6.x2.2
100.1.0 and 100.2.x10.5.1 is required to create geoprocessing packages and map packages for use with Local ServerNot supported
100.0.010.4.1 + PatchNot supported

Versions of supported specifications

Specifications supported in this release include the following:

  • GeoPackage versions 1.0, 1.1, and 1.2
  • Military standards APP-6(B), APP-6(D), MIL-STD-2525B (change 2), MIL-STD-2525C, and MIL-STD-2525D
  • Web Feature Service (WFS) versions 2.0.0 and 2.0.2
  • Web Map Service (WMS) versions 1.1.0, 1.1.1, and 1.3.0
  • WMTS version 1.0.0

On-premises virtualization

On-premises virtual desktop infrastructure (VDI)

VDI Requirements

On-premises virtual desktop infrastructureHypervisorNotes
VMware vSphere 6.7VMware ESXi 6.7Use VMware Horizon View 7.0.3 and later only.Use the latest VMware and NVIDIA drivers. See the VMware and NVIDIA GRID websites for the most current driver versions.
VMware vSphere 6.5VMware ESXi 6.5
Citrix Virtual Apps* and Desktops 7 1912 LTSRVMware ESXi 6.7*Deployment via Citrix Virtual Apps is not supported. Use the latest Citrix and NVIDIA drivers. See the Citrix and NVIDIA GRID websites for the most current driver versions.
Citrix XenDesktop 7.15 LTSR CU5VMware ESXi 6.7

Your browser is no longer supported. Please upgrade your browser for the best experience. See our browser deprecation post for more details.