Install Unreal Engine

The plugin supports Unreal Engine 5. The Epic Games Launcher provides a central location to manage your Unreal Engine installations, accounts, licenses, and projects.

Create an Epic Games account

In order to run the Epic Games Launcher, you need to have a valid Epic Games account.

To create an Epic Games account:

  1. Go to UnrealEngine.com.

    Unreal Engine home page

  2. On the top right corner, Sign in with Epic Games or Sign up.

Download and install the Epic Games launcher

  1. On the top right, select Download.

  2. Select the license that best suits your profile:

    • Publishing License: For game developers and other creators looking to monetize off-the-shelf interactive products

    • Creators License: For creators in industries outside of games working on internal and free projects, custom applications, and linear content, and for students and educators

      ArcGIS Maps SDK for Unreal Engine works with both licenses. For more information about Unreal Engine End User Licenses, visit Unreal Engine FAQ page.

      Select license

  3. Once the download is complete, run the installer to install the Epic Games launcher.

Install Unreal Engine

  1. After the setup program installs the Epic Games Launcher on your machine, use your Epic Games account to login.

    Sign into the Epic Launcher

  2. When the Epic Games Launcher opens, click Unreal Engine on the left side. the

  3. Click the Library tab, then click the Install Engine button. If you have any previous Unreal Engine versions already installed, click the + button next to the Engine versions and select Unreal Engine 5 from the version number drop-down, then click the Install button.

    Install Unreal Engine

  4. Choose a location for the Unreal Engine installation or accept the default location and click Install.

    Depending on your system specifications and environment, downloading and installing Unreal Engine will take between 10-40 minutes.

    Install Unreal Engine

Next steps

Your browser is no longer supported. Please upgrade your browser for the best experience. See our browser deprecation post for more details.