System requirements

The ArcGIS Maps SDK for Unreal Engine 1.1.0 supports Unreal Engine 5.0 (5.1 works but not fully supported). This page outlines the system requirements you need to use ArcGIS Maps SDK for Unreal Engine and Unreal Engine 5 on Windows, macOS, Android, and iOS.

ArcGIS Maps SDK for Unreal Engine system requirements (Unreal Engine 5.0)

Actual performance and rendering quality can vary depending on the complexity of your project.

Minimum software requirementsWindowsmacOS
Operating system versionWindows 10 version 1809 (build 17763) or highermacOS Big Sur or higher
DirectX RuntimeDirectX End-User Runtimes (June 2010)NA
Development requirementsVisual Studio 2019 v16.11.5 or later (recommended), Visual Studio 2022Xcode 12.4
Recommended hardwareWindowsmacOS
Operating system versionWindows 10 64-bit version 1909 revision .1350 or higher, or versions 2004 and 20H2 revision .789 or higher.Latest macOS Monterey
CPUQuad-core Intel or AMD, 2.5 GHz or fasterQuad-core Intel, 2.5 GHz or faster
Memory8 GB RAM8 GB RAM
GraphicsDirectX 11 or 12 compatible graphics card
  • DirectX 11: Latest drivers
  • DirectX 12: Latest drivers
  • Vulkan: AMD (21.11.3+) and NVIDIA (496.76+)
  • Metal 1.2 Compatible Graphics Card

    Mobile deployment system requirements

    Refer to Android Development Requirements for Unreal Engine 5.0 and Android Development Requirements for Unreal Engine 5.1 for Android system requirement.

    Refer to iOS Development Requirements for Unreal Engine 5.0 and iOS Development Requirements for Unreal Engine 5.1 for iOS system requirement.

    Some additional helpful links related to hardware and software requirements for Unreal Engine:

    Your browser is no longer supported. Please upgrade your browser for the best experience. See our browser deprecation post for more details.