System requirements

Operating System

The ArcGIS API for Python 2.2.0 is compatible with 64-bit versions of Windows, macOS, and Linux. Note that, 32-bit versions of Windows and Linux are no longer supported for API versions later than 1.7.1.

Python Version

Python 3.9.x to 3.11.x is required to use the ArcGIS API for Python 2.2.0.

Note: The arcgis.learn module is only supported with Python 3.9.x.


The full power of the ArcGIS API for Python is best experienced when all its dependencies are installed. However, specific tasks such as GIS administration and content management can be accomplished with a subset of dependencies installed. See Install with minimum Dependencies to install the arcgis package in this manner.

It is recommended to install the arcgis package the default way of either conda install -c esri arcgis or pipenv install arcgis. When version 2.2.0 is installed in this manner, all the below dependencies are automatically installed.

Note Most of these packages have dependencies of their own. For a full list of packages installed:

  • conda environment, type conda list -n <environment_name>.
  • pipenv virtual environment: See Pipfile and Pipfile.lock for details.

Note: if arcpy is found in the current python environment, it may be used in various locations. Otherwise, pyshp will be used. See Spatially Enabled DataFrame for more information.

Optional Dependencies

There are some other python packages that may be required to use certain functionality in the API, but are not automatically installed. To use that functionality, you must manually call conda install {package_name} or pipenv install {package_name} for such optional packages.

Your browser is no longer supported. Please upgrade your browser for the best experience. See our browser deprecation post for more details.